Server GAE (1.8.4) at localhost failed to start for the sample Stripes app

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Server GAE (1.8.4) at localhost failed to start for the sample Stripes app

wardlai
I was try to run the sample Stripes app (http://www.stripesframework.org/display/stripes/Sample+Application -> http://www.stripesframework.org/display/stripes/Download -> 1st link) on GAE (SDK 1.8.4) localhost using eclipse (Eclipse Java EE IDE for Web Developers; Version: Juno Service Release 2; Build id: 20130225-0426), but had the problem of "'Starting Google App Engine at localhost' has encountered a problem. Server Google App Engine at localhost failed to start." (see below image).




I imported the WAR file of the sample Stripes app (\stripes-1.5.7\examples\stripes-examples.war; see below image) using GAE as the server.




Appreciate any form of help! Do I need to use other IDE or server instead, like NetBean or TomCat?

I had no problem running a self-created GAE app.

I've set my default Java compiler to 1.6.

Here's my eclipse.ini contents:-
-vm
C:\Program Files\Java\jdk1.7.0_25\bin\javaw.exe
-startup
plugins/org.eclipse.equinox.launcher_1.3.0.v20120522-1813.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.200.v20120913-144807
-product
org.eclipse.epp.package.jee.product
--launcher.defaultAction
openFile
--launcher.XXMaxPermSize
256M
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
--launcher.defaultAction
openFile
-vmargs
-Dosgi.requiredJavaVersion=1.5
-Dhelp.lucene.tokenizer=standard
-Xms40m
-Xmx512m